[BUG] Plesk Panel Kurulum Hatası Çözümü: requires libMagickWand.so.5()

CodeIgniter Web Framework’te Production’a Geçiş
25 Mart 2020
WordPress’te SSL Kullanımı ve HTTPS Yönlendirme
28 Nisan 2020

Semptom:

Centos 7.8 ile birlikte Plesk Panel Obsidian sürümü kurulumunda aşağıdaki benzerlikte hatalar alabilirsiniz:

Exception: Failed to solve dependencies:
plesk-php73-imagick-3.4.3-1centos.7.200418.1216.x86_64 requires libMagickWand.so.5()(64bit)
plesk-php74-imagick-3.4.3-1centos.7.200418.1216.x86_64 requires libMagickCore.so.5()(64bit)
plesk-php73-imagick-3.4.3-1centos.7.200418.1216.x86_64 requires libMagickCore.so.5()(64bit)
plesk-php74-imagick-3.4.3-1centos.7.200418.1216.x86_64 requires libMagickWand.so.5()(64bit)

Exception: Failed to solve dependencies:
plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64 requires libMagickWand-6.Q16.so.6()(64bit)
plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64 requires libMagickCore-6.Q16.so.6()(64bit)
plesk-php72-imagick-3.4.3-1centos.7.200427.1953.x86_64 requires libMagickWand-6.Q16.so.6()(64bit)
plesk-php72-imagick-3.4.3-1centos.7.200427.1953.x86_64 requires libMagickCore-6.Q16.so.6()(64bit)

Çözüm:

Aşağıdaki adımları sırasıyla uygulayınız:

yum install ImageMagick -y
yum remove ImageMagick -y
wget https://rpmfind.net/linux/centos/7.7.1908/os/x86_64/Packages/ImageMagick-6.7.8.9-18.el7.x86_64.rpm
rpm -ivh ImageMagick-6.7.8.9-18.el7.x86_64.rpm

Yukarıdaki çözüm çalışmazsa, aşağıdakini deneyebilirsiniz:

rpm -Uvh http://mirror.centos.org/centos-7/7/os/x86_64/Packages/ImageMagick-6.9.10.68-3.el7.x86_64.rpm --nodeps
yum update -y

 

Artık Plesk Panel kurulumunu yeniden başlatabilirsiniz.

 

Bu makale yardımcı oldu mu?

Subscribe
Bildir
guest
0 Yorum
Inline Feedbacks
View all comments
Show Buttons
Hide Buttons